× This is the optional category header for the Suggestion Box.

Topic-icon Configuration problem [RU]

More
7 years 9 months ago #82

У меня небольшая проблема с конфигурацией. Пока стояла одна карта (decklink extreme 4k), все работало нормально (ввод и вывод через одну карту). В настройках клиента, правда, отображалось 2 устройства (Blackmagic WDM Capture и Decklink Video Capture), но проблем не было. Огромное спасибо за ваши турды. Решил расширить систему, нашел у компьюторщиков старую карту decklink sdi. Определилась, драйвера в стали, в клиенте появились Blackmagic WDM Capture (2) и Decklink Video Capture (2). Добавил в конфиге еще один канал - но не заработало. В тесте рекордеров отображается больше рекордеров чем есть на самом деле. К примеру, выбираю Blackmagic WDM Capture как input device, в тесте отображается 2 рекордера, причем показывает картинку с первой и второй платы. Выбираю Blackmagic WDM Capture (2) - в тесте один рекордер. И не завелся out. Что бы не делал - нет на выходе картинки, в некоторых конфигурациях при записи или при тесте, кортинка со входа идет сквознякос на аут. Снес драйвера, поставил по новой - "мнимых" устройств стало больше. При выборе Blackmagic WDM Capture - показывает 3 рекордера, причем один из них с названием Blackmagic WDM Capture (2). Если не выбирать никакое устройствокак input device - два "мнимых" рекордера все равно есть. И картинка при тесте/записи идет сквозняком. Может подскажите, куда копать?
В аттач добавлю логи старта и пару скринов для иллюстрации. У сожалению, не всегда имею доступ к компьютеру с каспаром, но по мере возможности буду выполнять все шаги. Заранее огромное спасибо.
С уважением, Григорий

File Attachment:

File Name: caspar_2016-10-14.txt
File Size:32 KB

File Attachment:

File Name: OpenSlo10o...2016.txt
File Size:8 KB







Предидущие логи тут

Last edit: 7 years 9 months ago by Kurylovich.

Please Log in or Create an account to join the conversation.

More
7 years 9 months ago #83

Приветствую, Григорий!

Давайте для начала определимся, что использовать WDM не стоит, они тормозные. Всегда в приоритете должно быть использование Decklink Video Capture.
Теперь хотелось бы немного прояснить схему подключения. Какие порты каких устройств у Вас принимают SDI сигнала, а через какое Вы его отдаёте? Из логов Каспара следует, что у Вас определились оба устройства, но вывод идёт через DeckLink SDI, т.е. в качестве входящего используются порты DeckLink 4K Extreme?

Please Log in or Create an account to join the conversation.

More
7 years 9 months ago #84

Здравствуйте, Антон
Да, я помню про замену.
Я уже не один приложил руки к конфигурации, и окончательно запутался.
Изначально был только DeckLink 4K и на нем in\out.
Потом, для теста, дошел старенький DeckLink SDI (при успехе, будет заменен на еще пару DeckLink 4К, но покупку нужно обосновать, а пока показать начальнику нечего).
Сейчас схема выглядт так: две платы на вход, и на одной из них еще вывод. В идеале, что бы in\out был на 4К, а на SDI только in. Сконфигурированно наоборот, т.к. завелось (последний раз) только наоборот.
Теоретичесеи, должно работать? Или я что то не так сконфигурировал (с каждым днем все больше в этом убеждаюсь)
И, почему-то, клиент ругается, если в
<consumers> не добавляю деклинки. Пишет, что declink и screen должны быть на одном канале

Last edit: 7 years 9 months ago by Kurylovich.

Please Log in or Create an account to join the conversation.

More
7 years 9 months ago #85

Так, Вы действительно запутались! :)
Начну издалека, отвечу на вопрос про "Пишет, что declink и screen должны быть на одном канале". Он всё правильно пишет, это зашито ему в логику работы. При классической схеме работы вывод должен осуществляться на второй монитор и какую-нибудь SDI плату, поэтому программа проверяет наличие <decklink><device>X</device></decklink> и <screen><device>1</device></screen> в тэге <consumers> и ругается, если не находит. Раз она ругается, значит каспар у Вас настроен неправильно.

Теперь по делу. Раз уж Вы запутались, предлагаю провести несколько тестов, чтобы распутаться!
Тест 1. Проверка работоспособности в Вашей системе Decklink SDI.
Для этого вынимаете из компа Decklink 4k, устанавливаете камеру и настройки Blackmagic в режим 720p50, скачиваете дефолтный конфиг отсюда , переименовываете, кладёте в папку каспара, запускаете всё, настраиваете Decklink SDI на 720p50 в OpenSloMo, игнорируете ругань на ошибку, описанную в начале и запускаете запись и/или тестирование. Если всё хорошо, всё должно записаться успешно. Сохраняете лог каспара и прикладываете на форум.
Тест 2. Проверка работоспособности в Вашей системе Decklink 4k.
Для этого вынимаете из компа Decklink SDI, вставляете Decklink 4k, устанавливаете настройки Blackmagic в режим 720p50, скачиваете второй дефолтный конфиг отсюда , переименовываете, кладёте в папку каспара, запускаете всё, настраиваете Decklink 4k на 720p50 в OpenSloMo, ошибка вылазить не должна, и запускаете запись и/или тестирование. Если всё хорошо, всё должно записаться и выводиться в Output SDI успешно. Сохраняете лог каспара и прикладываете на форум.
Тест 3. Совместная работа.
Снова вставляете Decklink SDI, устанавливаете настройки Blackmagic в режим 720p50. Запускаете каспар, сохраняете его лог и прикладываете на форум.

После этого будем разбираться, что у Вас происходит. Мне, например, крайне не нравится, что у Вас на скриншотах одни только WDM-устройства, а в логах каспара числится всего 2 устройства Decklink, а должно быть 3.

Please Log in or Create an account to join the conversation.

More
7 years 9 months ago #86

Ну и на всякий случай приложу часть конфига каспара для одновременной работы двух плат:

<channels>
    <channel>
      <video-mode>720p5000</video-mode>
      <consumers>
      </consumers>
      <index>1</index>
    </channel>
    <channel>
      <video-mode>720p5000</video-mode>
      <consumers>
      </consumers>
      <index>2</index>
    </channel>
    <channel>
      <video-mode>720p5000</video-mode>
      <consumers>
        <decklink>
          <device>3</device>
          <embedded-audio>true</embedded-audio>
        </decklink>
        <screen>
          <device>1</device>
          <windowed>true</windowed>
        </screen>
        <system-audio>true</system-audio>
      </consumers>
      <index>3</index>
    </channel>
  </channels>

Please Log in or Create an account to join the conversation.

More
7 years 9 months ago #89

Спасибо за помощь. Буду отписывать поэтапно.
Простое извлечение платы с удалением драйверов ничего не дало. Даже при отсутствии плат физически, клиент показывал мне 4 WDM Capture устройств в тесте. 3 нормальных и один с (2). Поудалял все что было из серверов, временные файлы связанные с каспаром, немного подчистил реестр (хотя там кроме ассоциации файлов вроде ничего не было), вставил одну плату (extreme). Установил драйвера. Теперь все показывает нормально (один wdm и один decklink) И в тесте только то устройство, что выбираю как input device

Last edit: 7 years 9 months ago by Kurylovich.

Please Log in or Create an account to join the conversation.

More
7 years 9 months ago #90

Тест 2 (4k extreme)
Единственное, поменял в конфиге папку с медиа (там лежаь 5 файлов из media.zip) и формат видео на PAL (в данный момент нет рядом ни конвертора, ни дрйгого сигнала).

Input device - decklink. В тесте показывает стопкадр входного сигнала. При нажатии запись - клиент вылетает. Файл создается размером 0 байт

File Attachment:

File Name: caspar_2016-10-17.txt
File Size:25 KB

File Attachment:

File Name: OpenSlo10o...2016.txt
File Size:1 KB

Attachments:
Last edit: 7 years 9 months ago by Kurylovich.

Please Log in or Create an account to join the conversation.

More
7 years 9 months ago #91

Подал 720p5994.
Есть подозрение, что declink sdi не воспринимается каспаром. Как бы я не бился, сейчас сигнал с этой платы получить в клиенте я не могу. Хотя прилага от blackmagic видит сигнал на ее входе. В тесте показывает черный экран (не серый, как когда на входе ничего нет) и запись крашится.

Please Log in or Create an account to join the conversation.

More
7 years 9 months ago #92

Т.е. получается, что при использовании 4k extreme в тесте изображение есть, а при старте записи приложение умирает с пустым файлом debug-лога, а с decklink sdi и в тесте изображение не ловится. Всё так?
Можете попробовать в Управлении устройствами операционки выключить все устройства Blackmagic с WDM и повторить тесты?

Please Log in or Create an account to join the conversation.

More
7 years 8 months ago #93

Доброго времени суток. Извиняюсь за долгое отсутсвие.
В конченом итоге, заставить работать одну и ту же карту (из тех что у меня есть) как in/out у меня не вышло. Если каждей карте давать одно задание - works like a charm.
Спасибо за потраченное время.
Конфиг в аттаче

File Attachment:

File Name: casparcg.config.txt
File Size:3 KB

Attachments:

Please Log in or Create an account to join the conversation.

More
7 years 8 months ago #94

Ну, Deckink SDI и не умеет одновременно in и out, у него только одна голова, поэтому необходимо выбирать. А вот Extreme и новые Decklink 4k должны уметь.
Я правильно понимаю, что в итоге завелась конфигурация с Extreme для двух входящих потоков + Decklink SDI на выход?

Please Log in or Create an account to join the conversation.

More
7 years 8 months ago #95

Я два потока не пробовал, если честно. Но, по идее, должна работать.

Please Log in or Create an account to join the conversation.

More
6 years 3 months ago #105

у меня такая же ситуация с decklink duo 2 надо принять сигнал и отдать уже готовый и обработанный реплей с замедлением ? мб кто поможет ! буду просто признателен и даже больше )

Please Log in or Create an account to join the conversation.

More
6 years 3 months ago #106

Добрый день. Здесь, в соседних ветках и в FAQ на сайте есть информация, как это можно реализовать. Вы пробовали? Возникли какие-то сложности?

Please Log in or Create an account to join the conversation.

Time to create page: 0.401 seconds